Перейти к основному содержанию
Тема: Mikrotik RB951Ui-2HnD настройка PPTP (Прочитано 18990 раз) предыдущая тема - следующая тема

Mikrotik RB951Ui-2HnD настройка PPTP

Доброго времени суток.
Пришло время сменить маршрутизатор, ранее стоял Zyxel. Интернет провайдер Netts. С интернетом через Zyxel или напрямую в компьютер с настройкой впн вопросов нет, всё работает прекрасно.
С микротиком возникли проблемы при настройке PPTP.

Далее выложу, что делалось, включая настройку локалки и пару скриншотов, что получилось в итоге. Может найдется человек, который подскажет, что делаем не так...


  • Обновили прошивку до 6.15, отказались от начальных настроек.

  • Сделали бридж со 2 по 5 порт  + закинули в него влан (пока не активен, настройки его без решения проблемы с PPTP нет необходимости).

  • В разделе ip-adresses добавили ip адрес 192.168.0.1/24  на интерфейс bridge1.

  • Зашли в ip-> DHCP server, далее DHCP setup. Выбрали интерфейс bridge1, указали   подсеть 192.168.0.0/24, шлюз 192.168.0.1, диапазон адресов 192.168.0.2 - 192.168.0.15, днс  сервер 192.168.0.1,  лизинг 3 дня.

  • IP- DHCP client на интерфейс ether1 ( в него воткнут интернет кабель). Галочки use peer dns, use peer NTP, выключено add default route. Остальное по дефолту.

  • PPP- добавили PPTP client
       Name -  pptp-out1.
       MTU по дефолту
       connectTo юзер, пароль, галочка dial on demand, галочка add default route
        allow - все галочки.


  • Делаем Nat, 2 правила:
       Первое:
       chain srcnat
       OutInterface pptp-out1
       Action masquerade
       Ok.
       Второе:
       chain srcnat
       src adress   192.168.0.0/24
       Action - masquerade


  • Перешли на вкладку Mangle, добавили:
       На вкладке General
          chain - prerouting,
          src.adress  192.168.0.2 - 192.168.0.15
       На вкладке Action
          action mark routing
          New routing mark PPTP
          галочка Passthrough

  •    IP - Routes, далее +
       dst.adress   0.0.0.0/0
       gateway  pptp-out1
       Routing mark  PPTP

  • IP-DNS
       Вкладка Static  и далее кнопка Settings
       10.24.72.7  (днс, который выдал провайдер)
       8.8.8.8
       8.8.4.4
       чекбокс Allow Remote Requests

  • Перезагрузили девайс для верности...

  • Наблюдаем, как не работает.


 

UPD
Убрали чекбокс Default on demand, поставили в dhcp client add default route на yes, получили pptp connected, но всё равно отсутствие интернета.



Re: Mikrotik RB951Ui-2HnD настройка PPTP

Ответ #1
Проблема решена. У кого возникнет, читайте про Dual Access. Читать  тут:  http://forum.mikrotik.com/viewtopic.php?f=2&t=72148
Решается костылем в виде маршрута.

Добавлю, 8 и 9 пункт в конфиге из 1 поста не нужны. И в нате немного другие 2 правила. Маскарад на WAN интерфейс и маскарад на PPTP.
Пункт 5, add default route yes. Пункт 6  Dial on demand off.

Re: Mikrotik RB951Ui-2HnD настройка PPTP

Ответ #2
Добрый день!

Почитал информацию по ссылке, но настроить так и не получилось:(
шлюз 10.10.32.1
WAN ip 10.10.32.49/24
VPN сервер с PPTP 10.10.0.12
Домашняя сеть 192.168.88.0/24

Подскажите плз, какие маршруты в результате правильные в вашем примере.
что  с нат?
У Меня вроде не Дуал Ацесс. Настройки статика. Провайдер сам не знает, что у себя настроил.

Mikrotik RB951Ui 2HnD настройка PPTP

Ответ #3
подборка )))

Mikrotik RB951Ui 2HnD настройка PPTP

Ответ #4
Да облом